Подключение нового объекта конфигурации к подсистеме внешних печатных форм

Здравствуйте.

Задача. Создать новый документ и добавить его в подсистему внешних печатных форм.

1. Чтобы добавить новый документ необходимо включить возможность редактирования нашей конфигурации.

Снять с поддержки конфигурацию

Редактирование с сохранением поддержки

2. Добавим новый документ с произвольной структурой

Новый документ

Также не забываем изменить описание и представление объекта.

3. В модуль менеджера документа добавить процедуры.


// Заполняет список команд печати.
// 
// Параметры:
//   КомандыПечати – ТаблицаЗначений – состав полей см. в функции УправлениеПечатью.СоздатьКоллекциюКомандПечати
//
Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
	
КонецПроцедуры

// Формирует печатные формы.
//
// Параметры:
//  МассивОбъектов – Массив – ссылки на объекты, которые нужно распечатать;
//  ПараметрыПечати – Структура – дополнительные настройки печати;
//  КоллекцияПечатныхФорм – ТаблицаЗначений – сформированные табличные документы (выходной параметр)
//  ОбъектыПечати – СписокЗначений – значение – ссылка на объект;
//                                            представление – имя области, в которой был выведен объект (выходной параметр);
//  ПараметрыВывода – Структура – дополнительные параметры сформированных табличных документов (выходной параметр).
//
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
КонецПроцедуры

4. В форме списка в командную панель добавим группу кнопок с именем «Подменю печать».

Форма списка подменю печать

5. В модуле формы списка добавим процедуры.


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	УправлениеПечатью.ПриСозданииНаСервере(ЭтотОбъект, Элементы.ПодменюПечать);
КонецПроцедуры

// СтандартныеПодсистемы.Печать
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
    УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Элементы.Список);
КонецПроцедуры
// Конец СтандартныеПодсистемы.Печать

6. В форме документа в командную панель добавим группу кнопок с именем «ПодменюПечать»

Форма документа подменю печать

7. В модуле формы документа добавим процедуры


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	УправлениеПечатью.ПриСозданииНаСервере(ЭтотОбъект, Элементы.ПодменюПечать);
КонецПроцедуры
// СтандартныеПодсистемы.Печать
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
    УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.Печать

8. В общем модуле «УправлениеПечатьюПереопределяемый» отредактируем процедуру «ПриОпределенииОбъектовСКомандамиПечати» сначала предоставив возможность редактирования в настройках поддержки.

общий модуль УправлениеПечатьюПереопределяемый

В конце процедуры добавим строку


СписокОбъектов.Добавить(Документы.БСП_НовыйДокумент);

9. Запускаем режим «1С:Предприятие» и с помощью обработки из набора внешних обработок библиотеки стандартных подсистем «ИнструментыРазработчикаОбновлениеВспомогательныхДанных.epf» обновляем наши новые данные.

Обновление вспомогательных данных
10. Протестируем наши доработки. Добавим внешнюю печатную форму в подсистему «Печатные формы, отчеты и обработки»

Добавление обработки

Внешняя печатная форма
Откроем форму списка и выведем на экран команды печати

Команда внешней печатной формы

Результат печатной формы

На этом подключение нового объекта к подсистеме внешних печатных форм завершено.

Популярность: 3%

Запись опубликована в рубрике Настройка и оптимизация с метками . Добавьте в закладки постоянную ссылку.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *