Подключение нового объекта конфигурации к подсистеме дополнительных отчетов и обработок

Здравствуйте.

В данной заметке будет описан алгоритм действий подключения нового объекта (например документа) в типовой конфигурации 1С к подсистеме «Дополнительные отчеты и обработки».

Пример будет рассмотрен на конфигурации «1С: Управление торговлей 11.2», но все действия, рассмотренные в статье, можно применять и к другим конфигурациям (ЗУП 3, БУ 3, ERP 2 и т.д.).

1. Чтобы добавить новый документ необходимо включить возможность редактирования нашей конфигурации.

Снять с поддержки конфигурацию

Редактирование с сохранением поддержки

2. Добавим новый документ с произвольной структурой

Новый документ

3. В формы документа (списка и объекта) необходимо добавить следующий код (не забываем при этом для форм определить процедуру «ПриСозданииНаСервере»)


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ДополнительныеОтчетыИОбработки.ПриСозданииНаСервере(ЭтотОбъект);
КонецПроцедуры

#Область ОбработчикиКомандФормы
// СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки
&НаКлиенте
Процедура Подключаемый_ВыполнитьНазначаемуюКоманду(Команда)
    Если Не ДополнительныеОтчетыИОбработкиКлиент.ВыполнитьНазначаемуюКомандуНаКлиенте(ЭтотОбъект, Команда.Имя) Тогда
        ДополнительныеОтчетыИОбработкиВыполнитьНазначаемуюКомандуНаСервере(Команда.Имя);
    КонецЕсли;
КонецПроцедуры
// Конец СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки
#КонецОбласти

#Область СлужебныеПроцедурыИФункции
// СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки
&НаСервере
Процедура ДополнительныеОтчетыИОбработкиВыполнитьНазначаемуюКомандуНаСервере(ИмяЭлемента)
    ДополнительныеОтчетыИОбработки.ВыполнитьНазначаемуюКомандуНаСервере(ЭтотОбъект, ИмяЭлемента);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки
#КонецОбласти

ПриСозданииНаСервере

4. Для определяемого типа «ОбъектСДополнительнымиКомандами» необходимо добавить наш новый документ, но для этого надо сначала дать возможность его редактировать.

ОбъектСДополнительнымиКомандами

ОбъектСДополнительнымиКомандами

На этом работы в конфигураторе завершены.

5. Запускаем режим «1С:Предприятие» и с помощью обработки из набора внешних обработок библиотеки стандартных подсистем «ИнструментыРазработчикаОбновлениеВспомогательныхДанных.epf» обновляем наши новые данные.

Обновление вспомогательных данных

Чтобы проверить результат, добавим внешнюю обработку по заполнению.

Добавление обработки

Добавление обработки

После успешного добавления, проверим результат в формах документа.

Форма списка
Внешняя обработка в форме списка

Форма документа
Внешняя обработка в форме документа

На этом все, как видите ничего сложного.

Популярность: 3%

Запись опубликована в рубрике Настройка и оптимизация с метками . Добавьте в закладки постоянную ссылку.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *